Raspberry PI 3 Audio


#1

Hey

Has anyone managed to get audio to work on Raspberry PI 3?
I’m getting Empty DeviceRef error thrown and audio::Device::getDefaultOutput() is returning null.

Is there anything I need todo to get pulse audio to work with cinder?
I can get audio to work with other programs.

Any help would be greatly appreciated :slight_smile:


#2

I got it to work following this:
I have got it working on my Raspberry Pi using the ALSA sink, with procedure as follows:

To install the necessary files:

sudo apt-get install pulseaudio pulseaudio-module-zeroconf alsa-utils avahi-daemon
To enable ALSA:

sudo modprobe snd-bcm2835 # load module for single boot
echo “snd-bcm2835” | sudo tee -a /etc/modules # load module for persistance
To set up networking:

sudo nano /etc/pulse/default.pa
and uncomment the lines:

load-module module-native-protocol-tcp auth-ip-acl=127.0.0.1;192.168.0.0/16
load-module module-zeroconf-publish
To start the pulseaudio server, use:

pulseaudio -D
You should be able to test that it works by playing a wav file with paplay (sudo apt-get install pulseaudio-utils), and also over the network by selecting the sink in your system’s sound control panel.

You might be also be able to set up in system-wide mode with:

sudo pulseaudio --system


Cinder Audio Linux Pi 2/3