Cannot open input file 'cinder-v140.lib'


#1

Hi all,

I’ve built cinder using the 140 tools from VS2015 Pro.
When I try and build my project that uses cinder the linker is complaining:

LINK : fatal error LNK1181: cannot open input file ‘cinder-v140.lib’

but the only file I have is

Cinder\lib\msw\x86\Release\v140\cinder.lib

Can anyone point out what I’m doing wrong - I’m using the same VS Project successfully in two other locations and have setup the project the same way as far as I can tell.

Any help appreciated.

Dave


#2

Hi,

I assume you’re using the latest master branch? Have a look at this post: very recently the location of the lib files were changed. Chances are your project settings need to be updated, specifically the linker settings for your libraries and additional directories.

-Paul


#4

That’s exactly what I was after, thanks appreciate the help - I decided it was best to rebuild and start a new project in the end, and cloned the latest master branch. Cinder now won’t build at all the first error being:

Error C2027 use of undefined type 'std::basic_ofstream<char,std::char_traits<char>>' cinder c:\dev\cinder\src\cinder\utilities.cpp 104

followed by:

I’m completely stumped. All i’ve done is recursive clone, and build the 2013 project (after conversion)

And this is what I get - any help greatly appreciated.

Cheers

Dave


#5

The problem is here:

"incomplete type is now allowed"


#6

I’ve found that vc is a lot more of a sook when it comes to includes than other IDEs / compilers. Can you try explicitly including <fstream> in Utilities.cpp and rebuilding cinder?