Running on a Rapberry PI 4 [solved]


Was looking into to possibility of setting up a new project on the raspberry pi4.
But I wasn’t aware that with new PI came with a new gpu and drivers.

I can build cinder and the examples but when I run it I get a.

* failed to add service - already in use?

From what I could understand by reading the internet is that the PI4 works more like regular linux setup and apps should run on X?
So I also tried to build it as regular Linux but than run in some compile errors.

Anyone has successfully run Cinder on a PI4?


Hi Kris,

A couple of months ago I got my hands very briefly on an RPi4 and tried out building Cinder with success. Here is a screenshot that I took back then of the Deferred sample running on device.

You basically need to 2 things as far as I remember for this to work. First would be to install the X dependencies ( along with the standard RPi3 dependencies ) which are not part of Cinder’s RPi guide currently:

sudo apt install libxrandr-dev \
libxinerama-dev \

Second would be to use Cinder’s es3 GL target when building the library and/or samples:

cmake .. -DCINDER_TARGET_GL=es3

I believe these should be the only two things needed in order to get up and running on the default RPi4 setup.

Hope this helps,


Wauw Petros, this works!

Thank you very much and also all the other people who contributed to this linux port.
I feel the pi 4 is really a gamechanger for cinder projects. It’s really fast compared to the old models.