Android build on Linux


I am trying to set up an android build on linux. Earlier I successfully used it in macOS, but on linux it seems much more complicated.
I installed Android Studio 3.4.1, Sdk 19, Ndk. Also downloaded jdk1.8.0_211.
It seems that the build was made for gcc-4.9, but now only clang is in the toolchain.
I run the build like this:

export NDK_ROOT=~/Android/Sdk/ndk-bundle; ./fullbuild-armeabi-v7a -clang -v -n $NDK_ROOT

Received many errors about missing headers, although the ${NDK_ROOT}/sources/cxx-stl/llvm-libc++/include path is set and exists.

Full list of errors:

Has anyone gotten this to work? Any help would be greatly appreciated.


I found a workaround by installing NDK 15c from
This NDK still contains the toolchain Cinder was prepared to build with.


1 Like

Can you point to me how you got the Android build working on macOS? All the docs I’ve found seem outdated.

I’m not familiar with android development, so I tried to make it work with old tools. I installed sdk 19 and 21, and ndk 15c. You also have to change some paths. These are the changes that worked for me. You don’t have to apply the ones in unless you would like to play videos from files instead of assets.