Jing Assimp Lib (Solved)


#1

Trying out Jing’s Assimp block in vc2015… https://github.com/jing-interactive/Cinder-Assimp
I was able to build assimp.lib and assimp-d.lib along with cinder-assimp.lib and cinder-assimp-d.lib after doing “premake5 vs2015”.
for some reason, Tinderbox won’t let me copy the block…so I used relative path…
But as soon as I get to the line
mActor = SkeletalMesh::create(AssimpLoader(loadAsset("astroboy_walk.dae")));
in the example I get an out of range memory
The asset folder with the example doesn’t have astroboy_walk.dae but even when I put it in there, I get the same error even though the file loads into the official assimp viewer app just fine.
Perhaps it is related to not being able to copy the static libs? Any help would be appreciated. Been trying to get assimp working for weeks now.


#2

I almost forgot…
the example has #include "Cinder-Assimp/include/AssimpLoader.h"
but there is no include folder so I copied the files from the src folder into a new include folder.
Then I changed the line to #include “AssimpLoader.h”
Why do I feel like I’m doing something horribly wrong with the static libs?


#3

I was kindly informed that the example code was never to work. Instead, this block is meant to be used in conjunction with Jing’s Renderdog and I got it working in no time. Thanks Jing!