Kinect Cinder9.0 OSX

Has anyone gotten Kinect working on Cinder9.0+? I’m running osx10.11 and cant get any of the Kinect blocks working at all.

I used this fork about a year ago with Cinder 0.9+ on OSX:
the xcode project files might not be updated, though, because i was building from the command line.

Are you using the Kinect v1 or v2?

This was for Kinect v1, i also have a more or less working solution for Kinect v2 on osx/linux using libfreenect2 if someone is interested.

@gabor_papp is that everything except skeleton on OSX?

The blocks are using OpenKinect’s Freenect and Freenect2, so no skeleton. Although it is probably possible if you combine it with OpenNI.

Thanks @gabor_papp !!!
Been a while since I could come back to this but your branch finally did the job!
However, It still seems like the depth data is really squished compared to the openframeworks kinect library which is way more physically accurate. I always had this issue with Cinder though… Suppose it’s because I have model 1414 of the kinect? I think I tried to replace the depth reading bits a few years ago once… but it was beyond my coding abilities at the time.

I don’t think it is because of the kinect model you have. More like how Cinder-Kinect processes the depth data here:
It looks better visually, but it loses some precision. If you change this part it can work better for your use-case.

Cool, yea I remember looking at that line a while back.
I did end up finding this github with a depth scale function that works too…

New/old problem… The kinect rgb image still doesn’t line up properly because the kinect isn’t set to registered for some reason. Setting the device to registered also completely messes up the depth values again. It’s on line 215 right above your link.

it says // max depth value is 10000 in registered mode
Instinctually I just replaced that line with line 221 but that messes it up even more. I’m thinking there could be an offset I’m overlooking now.

gonna try to use freenect_camera_to_world instead…