Trying to build the BasicApp sample on Raspberry Pi 4 (rpi os / Linux)

I have successfully built Cinder lib with:

cmake -DCINDER_TARGET_GL=es3-rpi -S . -B ../../build/ ..
cmake -DCINDER_TARGET_GL=es3-rpi -DCMAKE_BUILD_TYPE=Release -S . -B ../../build/ ..
make -j3

But when trying to build the BasicApp sample with:

cmake -DCINDER_TARGET_GL=es3-rpi -S . -B ../../build/ ..    (From BasicApp/proj/cmake)
make -j3				  (From BasicApp/build)

I get this error:

  • undefined reference to `std::filesystem::__cxx11::path::has_parent_path() const’

and it seems to originate from:

I have tried to build with booth GCC and Clang, resulting in the same error.
Any ideas on how to fix this?

Ok, I had to force the compiler to use C++11, now it works!
I changed the CINDER_CXX_FLAGS in the file: Cinder/proj/cmake/libcinder_target.cmake
Then I re-build Cinder libs and then I could finally build The BasicApp sample! :grinning:

Other than that problem follow this great guide by @num3ric to build Cinder on Raspberry Pi 4: By the way why isn’t that guide out on this libcinder page: Cinder on Linux …it should be?