Android VideoPlayer 0 size texture


I’m trying to load a movie from and android tablet sdcard, and the video size and the size of the returned texture is (0, 0). Has anyone encountered this issue before? The video can be played on the tablet, so I assume it is not a codec issue. Any suggestions would be appreciated how to tackle this problem.


It seems that Cinder on Android assumes that your videos are stored as assets. I’m trying to change the libcinder java sources similarly to @eight_io’s solution (Files cannot be read in Documents directory by Android Cinder?).

I had to change the paths in proj/android/libcinder_java/build.gradle to "${projectDir}/../../../tools/android/CinderAppBuild/repo" and /proj/android/libcinder_java/libcinder/build.gradle to "${projectDir}/../../../../src/cinder/java".
Now the project almost builds:


Total time: 5.307 secs

FAILURE: Build failed with an exception.

* What went wrong:
Failed to notify build listener.

I tried to update gradle, but I got an error:

* Where:
Build file '.../cinder/proj/android/libcinder_java/app/build.gradle' line: 1

* What went wrong:
A problem occurred evaluating project ':app'.
> Failed to apply plugin [id '']
   > Gradle version 2.2 is required. Current version is 4.4.1. If using the gradle wrapper, try editing the distributionUrl in ...cinder/proj/android/libcinder_java/gradle/wrapper/ to

changing this to results in the same error.

build tools: 28.0.3
android studio: 3.4.
ndk 15c
sdk 19 and 21

Any help or suggestions would be really appreciated.


Managed to find a way to solve this. The output lib path was wrong and also had to update gradle. I post the changes that worked for me in case someone would like to build the java classes in the future.