iOS 11 & Cinder

Hi There,

I recently tried to use Cinder + iOS 11 (used tinderbox to make a project & also tried the cube sample) and the app crashes (freezes) upon launch, any tips / points on how to get this working? @andrewfb @wdlindmeier @paul.houx @Simon @notlion @ryanbartley?

Any help is appreciated!


P.S. Thanks again for Cinder :slight_smile:

I haven’t tried to run Cinder on iOS11 myself, but I think you should check which version of OpenGL is supported. It’s probably OpenGL ES 3.0 or higher. This may mean you’ll have to build Cinder using the CINDER_GL_ES_3 define, see this old post for more info.


Well that’s worrying. I haven’t tested on iOS11 yet, but I’ll need to look into this before launching the next Seaquence update. Keep us posted if you find out what the cause of the crash is!

BTW ES3 is the default on iOS now. You need to define CINDER_GL_ES_2 to downgrade:

I can’t speak to the OpenGL renderer, but I’ve been using the Metal renderer on iOS11 for a month or so now without any issues.

Can you post a stack trace of the crash?

Just started testing this. Cube example does indeed crash with a bad access exception in flushBuffer here:

Happening both in ES3 and ES2 versions of Cinder. Not sure what the bad access is though. The EAGLContext seems to be valid.

Temp fix seems to be disabling GPU frame capture. Hopefully this is something that will be fixed by the time iOS 11 is out of beta.

Thank you @paul.houx @notlion @wdlindmeier @andrewfb for the quick responses. I was able to get up and running by disabling the GPU Frame Capture.

@wdlindmeier this is so awesome, gonna poke around this weekend!