Building using Visual Studio 2017


Does cinder supports VS 2017 yet? Tried to building from fresh source from git, not working though.
If anybody do got it to work, please tell me how?


VS 2017 hasn’t been officially released yet (I believe it drops tomorrow), however I tested with the latest RC and it worked for me, both building with v140 and v141. The IDE itself was still a bit buggy, though, and was hanging up so I switched back to 2015.



Is the instructions is still the same?
I followed one here:
and here:

in windows setup page, the link in the bottom is broken (


It works fine with VS 2017 Community, using Windows 8.1 SDK and v141 (I haven’t tested with Windows 10 SDK)


I guess that’s the problem I have. I didn’t have Windows 8.1 SDK. I only have Windows 10 SDK.


I’m revisiting cinder after few months. Still couldn’t get it to build using Windows 8.1 SDK and v141. I must have missed something here.
I’m using VS2017 latest patch.
I tried the VS2015 solution from the cinder_master\proj and retarget to Windows 8.1 SDK and v141. The build failed with missing include file: ‘corecrt.h’.
I tried making VS2017 solution using latest Cmake, failed to build again. with bunch of errors.
What are the correct steps here??
I prefer not to install VS2015 because of lack of space on my SSD.


I’m working with vs2017 and think I have both 8.1 and 10 SDK’s.
Have you tried just opening the cinder.sln located in cinder_master\proj\vc2015 with vs2017?
That’s what I did, just agreed to upgrade to v141 comlpiler when promped.


Yes, that’s exactly what I did. vc2015.sln.
I install 8.1 SDK.
seems like corecrt.h is the only missing file here. Do you know what the file is for? it doesn;t look it belong to cinder.


The project shows it’s located at
C:\Program Files (x86)\Windows Kits\10\Include\10.0.10240.0\ucrt

Looks I’m with SDK 10.


Hey, just a thing to try, but for me when it prompts me to convert, even after it says it’s successfully completed, i still have to manually right click on the project and edit the SDK and occasionally platform toolset, because visual studio is a piece of shit. Any chance the same is happening to you?


I change from W8.1 to W10 SDK. It magically succeed the build. :smiley:
How do I close this thread?